ICDL Using a Computer Chapter 1. Computer Environment

From MEPIS Documentation Wiki

Jump to: navigation, search

http://www.openicdl.org.za/devcourses/mod2/mandrake/module2-all.html

ICDL License terms; Attribution-ShareAlike



Contents

Chapter 1. Computer environment

First Steps with the computer

Start the computer

  • Press the On/Off switch on front of the computer.

This will initiate the boot process. During this process the start-up routines that are stored in the ROM of the computer will take control of the computer. One of the things these routines do is to read certain areas of the hard drive to search for the operating system. The start-up routines will then load the operating system into the RAM of the computer and pass over control to it.

Depending on how the computer has been configured, one of three things will happen:

  1. The operating system will automatically load the GUI (graphical user interface) and start this for a default user. The system will be available for immediate use;
  2. The operating system will automatically load the GUI, but you will be prompted to enter a username and password. These will be given to you by who ever installed the system;
  3. Only the text-based operating system will load. In this case you will need to logon and then start the GUI. In this case you will see a black screen on which the prompt Logon: appears.

Suppose you have been given the username GenUser and password V2wTkN7. Remember that passwords are case sensitive. If you are given a password, you must enter it exactly as given.

Logon to the GUI

  1. When the logon window appears, type in your username and password exactly as given. When you type the password, for example V2wTkN7, a series of stars ****** will appear in the password window. This is so that no-one can read your password by looking over your shoulder.
  2. Click the login button.

Logon to the text-based interface and then load the GUI

  1. From the prompt screen click 'session type' and select 'failsafe'
  2. Type your username (e.g. GenUser) after the logon prompt and press Enter.
  3. When asked for your password (e.g. V2wTkN7), type it in and press Enter.
  4. Type startx and press Enter. This command will load the GUI after you have logged on.


  • Unless you have a valid username and password, you will not be able to log on to the system. Speak to the system administrator if you cannot log on.
  • In Linux, there is a special user logon called root which has complete access to the system. When a user logs on as root, he or she can do anything on the machine. Even if you know the root password, do not log on as this user unless you are carrying out special administrative activities. For ordinary use, you should use a username that has more restricted access.

Shut down the computer

  • Please take note that shutting down and restarting your computer will not be available on a thin client. This function will be controlled by the network administrator.
  1. Click the Start Applications icon at the bottom left of the screen.
  2. Click Logout on the main menu.
  3. Click the Turn off computer radio button in the dialogue which appears and click OK.

Logout.png


  • Never just shut the computer down by pressing the On/Off switch.

Restart the computer

The appropriate routine

Follow the same method as for shutting down the computer except for the last step, in which you select the Restart computer button.

Shut down a non-responding application

It may happen that an application freezes and will not respond to mouse clicks or keyboard commands.

  1. Give the application a while. It sometimes happens that a non-responding application "wakes up".
  2. If not, click on the Start Applications icon.
  3. Click the following in sequence: Start Application->System->More Applications->Performance monitor (KsysGuard).
  4. Click the Process tab.

Ksysguard1.png


  1. Select All Processes.
  2. Highlight the application that is not responding.
  3. Click the Kill icon to shut down the application.
  4. When done, File->Quit or press Ctrl+Q or click the Close icon in the top right of the screen.


  • You can also use Ctrl+Alt+Esc which turns your cursor into a skull and crossbones. Just click the application window that you want to close. Be careful with this, it will close any and all applications! Do not click the menu bar at the bottom! Doing so will close it and the only way to recover is through Ctrl+Alt+Backspace to restart the GUI.
  • With 7.0 "Ctrl+Alt+Esc" will turn your regular mouse pointer into an X which works the same as the skull and crossbones.
  • If you want to try "Ctrl+Alt+Esc" go ahead. If you have nothing to kill with it then just hit "Ctrl+Alt+Esc" again and the X or skull and crossbones will disappear and the normal mouse pointer will be back.

What to do if the entire system freezes

  • If the entire system freezes, do not immediately switch of the system with the power switch. This could cause serious damage to the entire system. This is a last resort only. The most likely cause of a frozen system lies with the GUI.
  1. Wait a while. The system may wake up of its own accord.
  2. Press Ctrl+Alt+Backspace to restart the GUI.
  • This will cause you to lose all unsaved work, but it will preserve the system itself.

Basic information and operations

Abstract

View the computer’s basic system information: operating system and version number, installed RAM (random access memory).

View CPU information

  1. Start Applications->System->Info Center->Processor

Infocentre-processor.png


Click Close when done.

View RAM details

  • Start Applications->System->Info Center->Memory

Infocenter-mem.png

View operating system version information

This information can also be found in a number of places. For example:

  • Start Applications->All Applications->Browse All->Apps->System->K Control. This displays the KDE Control Centre.

Kcontrol.png


This gives you details of the Linux kernel you have installed on your system. In this case it is version 2.6.15-27-desktop.

Each of these numbers has a special meaning:

2: The second major release of the Linux kernel.
6: The 6th minor release of the second major release. If this is an even number it denotes that it is a stable kernel release. If it were an odd number, it would indicate that the version is not yet fully tested.
15: The 15th patch of the above release. A patch contains minor corrections to a version.
27: Build 27. A build contains even smaller changes than those found in a patch.

Configuration

Abstract

Change the computer’s desktop configuration: date & time, volume settings, desktop display options (colour settings, screen pixel resolution, screen saver options).

  • In order to make some of the changes to the system, you will need to know the root password.


Set the date and time

  1. Right click on the clock in the bottom right of the screen to display a context menu.

Clock.png


  1. Enter the root password when prompted.
  2. Adjust the date and time on the calendar and clock.
  3. Click OK when finished.


An alternative method is to do the following:

  • Start Applications->All Applications->Browse All->Apps->System->K Control->System Administration->Date & Time.

Set the volume level

If you have a speaker icon next to your clock, left click on that icon and:

  • Just slide the bar to adjust the volume.
  • You can click Mixer at the bottom of this to bring up the KMix window for more complex sound adjustments.
  • Clicking the green circle will put you on, or take you off mute.

Alternatively, you can right click it, which allows you to select Mute, Select Master Channel, Show the Master Window (Kmix,) or Quit.


If you don't have the speaker icon, you can open KMix by:

  1. Start Applications->Multimedia->KMix.
  2. Adjust the volume level using the left-most slider.
  3. File->Quit or click the Close icon when done.

Getting information on your sound card

  • Start Applications->System->Info Center->Sound.

Infocenter-sound.png

Set desktop options

The main method of changing the appearance of the desktop is through:

  • Start Applications->System configuration->Appearance & Themes and select what you want to change.
  • You can also right-click on the desktop itself and select Configure Desktop from the menu.

Change the colour settings

  1. Start Applications->System configuration->Appearance.

Appearance-colors.png


  1. Select the color scheme, or create your own!
  2. Adjust the contrast, if necessary.
  3. Click OK when done.

Change the screen saver

  1. Start Applications->System configuration->Appearance->Screen Saver.

Appearance-scrnsaver.png

  1. Select the screen saver, and set how long the system has to be idle before the screen saver starts.
  2. You can also check the Require password to stop box, which means you have to enter your password when you wanted stop the screen saver and return to your desktop.
  3. Click Apply.

Disable the screen saver

  1. Click the Start screen saver automatically check box. This will grey out the rest of the settings options below.
  2. Click Apply.

Set the desktop background

  1. Start Applications->System Configuration->Appearance->Background
  2. Configure the background as you want, such as adding a background wallpaper or having just a solid color.
  3. Click OK when finished.
  • Thin clients may permit you to make these changes but may not store them at the end of your login session. Speak to your system administrator about whether individual user profiles are available or whether each login starts with a fresh default profile.

Set the screen's pixel resolution

  1. Start Applications->System Configuration->Peripherals->Display
  2. Adjust the screen resolution using the drop down boxes
  3. Click Apply when done.


If the screen resolution you're looking for is not there, (like you're stuck in 640x480)...

  • If you installed or are booting from a LiveCD, did you press F3 on the boot selection screen to select your resolution?

If you did not press F3, please visit Monitor Resolution for solutions.

Set and change the keyboard language

The keyboard language defines the position of the various keys on the keyboard. For example, British, American and French keyboards all have different layouts. If some of the keys generate a different letter to that shown on the key itself, it could be that the keyboard language setting needs to be changed.

  1. Start Applications->System Configuration->Regional & Accessability->Keyboard Layout.
  2. Select the keyboard layout desired.
  3. Click Apply when done.

Keyboardlayout.png

Formatting Removable Disk Media

Abstract

Format removable disk media: diskette, Zip disk. We should link to a hard-drive format wiki here, please help!

Before data can be saved on a disk, the disk has to be prepared. The process of preparing a disk to store files is called formatting. If a disk has been previously formatted, formatting a second time will result in the loss of any data that may have been stored on it.

Formatting removable disks in Linux
Formatting For use by other OS as well as Linux For use only by Linux
Floppy (fd0) /sbin/mkfs.msdos /dev/fd0 /sbin/mkfs.ext2 /dev/fd0
Zip Disk (sd0) /sbin/mkfs.vfat /dev/sd0 /sbin/mkfs.ext2 /dev/fd0

cf. terminology in Windows: c: = hard disk a: = disk drive / floppy d: = CD-ROM

Format a floppy disk

  1. Make sure the disk you wish to format does not contain any data you will need.
  2. Insert the diskette into the diskette drive.
  3. Start Applications->Utilities->Peripherals->Floppy Formatter (KFloppy)

Kfloppy1.png

  1. Select the File system required (NB: If you use DOS, you will be able to share the disk with Windows users. If you use ext 2, you will only be able to share it with Linux users.).
  2. Give the diskette a label. This is the electronic label that the formatting process attaches to the disk.
  3. If the disk has been formatted previously, you can select Quick format; this makes use of the previous format to speed up the process.
  4. Click Format.

Once the disk has been formatted, you can save files to it.

Format a diskette using a terminal

An alternative method of formatting a floppy disk is to open a terminal and type in the appropriate command.

Terminal windows give you access to the full power of Linux. The GUI simplifies the process of executing much of the power of Linux. Typing in the actual commands at the command prompt allows you to execute all the variations of Linux commands.


To open a terminal, go to Start Applications->System->Terminal program (Konsole).


To format a floppy disk:

  1. Insert the floppy disk to be formatted.
  2. Type in the command
/sbin/mkfs.msdos /dev/fd0

Be sure it's entered exactly as shown, you can copy it (ctrl+c) and paste it in the terminal using shift+insert. Then press Enter.

Formatfloppy.png


  • When you use a terminal to enter commands, you must press the Enter key at the end of each line.
  • Commands are case sensitive. If a command does not work, check that you are typing the command exactly as required. For example, mkfs is correct but Mkfs or MKFS will not work.

Format a zip disk for use in Linux only

If you wish to format the diskette in Linux format, (be aware that you would not be able to share the disk with Windows) you would use:

/sbin/mkfs.ext2 /dev/fd0


In order to format a zip disk, you would need to use a terminal.

  1. Insert the zip disk to be formatted.
  2. Start Applications->Terminals->Konsole.
  3. Type in the following command:
/sbin/mkfs.ext2 /media:/fd0

And press enter.

This will format the zip disk in ext2 format. This disk can only be shared with Linux users.

Format a zip disk to share with Windows users

If you wish to share the zip disk with both Linux and Windows users, you will need to use the vfat file system.

  1. Insert the zip disk to be formatted.
  2. Start Applications->Terminals->Konsole.
  3. Type in the following command exactly as shown and press Enter: /sbin/mkfs.vfat /dev/sd0.


Installing and uninstalling

Abstract

Install, uninstall a software application

This section needs re-writing to cover Synaptic and apt-get - please help!

Using Print Screen for screen captures

Abstract

Use keyboard print screen facility and paste contents into a document.

You can take a snapshot of the screen and save it as an image file.

There are two ways to open KSnapshot, which is a screen capture program:

  1. Press the Print Screen button on the keyboard. It may be abbreviated to Prt Scr or similar. This activates KSnapshot.
  2. Or, you can open KSnapshot through Applications->Graphics->Screen Capture Program (KSnapshot).

Ksnapshot.png

It automatically takes a snapshot upon loading, if you want to take another, just click New Snapshot.

To save:

  1. Click the Save Snapshot button.
  2. Specify a name and location in which to save the snapshot.
  • The snapshot is automatically be saved in png format, but you can select a different format with the Filter drop down menu beneath Location.


The image can now be inserted into a document in the same way you would insert any graphics file by opening the document and doing the following:

  1. Click on File->Insert->Graphics.
  2. Browse to the directory / folder containing the file.
  3. Click the filename of the graphic you wish to insert and click Open or simply double click on it. This will insert the graphic into the document at the current cursor position.

Use available Help functions

The KDE desktop comes with a number of manuals in electronic form.

  1. Start Applications->Help
  2. Click KDE User's Manual to expand its contents.

This section needs expanding - please help!

Print Help

If you find it difficult to read the help on the screen, you can print the contents of the current window.

  • File->Print.

Searching in Help

The search function only allows you to scan the currently displayed topic.

  1. Edit->Find or press Ctrl+F.

Help-find.png


  1. Enter the text you wish to find. Notice the various options that you can set when carrying out a search.
  2. Press OK.

The first occurrence will be highlighted in the text of the help. You will be prompted if you wish to locate the next occurrence.

Using Help as a tutorial

Become as familiar as possible with the help system. These notes will provide you with an introduction to Linux using the KDE desktop. When you have worked through a section in these notes, you could read what the KDE help system has to say on the topic. If you wish to become an expert, you will need to read further and discover the full power of Linux and KDE. The help system is the best place to start.

Text editing

Abstract

Launch a text editing application. Open, create a file.

Starting the text editing application

  1. Click on Start Applications
  2. Click on Office->Editors->Text editor (KWrite).

The KWrite editor program will pop up. There are other editors available, but we will use KWrite for now. The components of the screen are shown below.

Kwrite.png


  • Because we will be making extensive use of the Menu bar, we will make use of the following convention in using the functions of the menu bar. So, File->Save will mean exactly the same as clicking File on the Menu bar and then the Save option.


Open a file

One of the advantages that text editors provide for us is the facility to save our work and recall it at a later time. We can then print our work or make further changes (edit). In addition, we are able to create many versions of the same document, each of which can be saved on our hard drive under an appropriate name.

To open a document:

  • File->Open.
The Open dialogue will appear. In general, this will point to your home directory.
In this case, the Open dialogue is pointing to the directory /home/username/ (in this example, the username is kate).

Kwrite-open.png

  1. If necessary, navigate to the desired directory.
  2. Highlight the file you wish to open.
  3. Click OK.

If you wish to open a file contained on your floppy or a seperate hard-drive, click Storage Media to the left and pick your hard drive or floppy device. Or, type /mnt/floppy or /mnt/ in the top field bar and press enter.

  • Your harddrives will be lists as hd-letter+number, usually 'hda1' or 'hdb1'. (It's shorthand for hard drive <a/b/c or d>, partition <1/2 or 3> etc.)


On the top right of the Open dialogue, there are a few important buttons for easy navigation:

  • The upward pointing arrow will move you to the parent of the current directory. In the case of the screenshot, pushing this button would move you from /home/kate/ to /home/. You can return to the user directory you started out in at any time by pressing Home Folder.
  • The folder button with the star allows you to create a new directory in the current directory. In order to be able to do so, you will need the appropriate user rights. (If you're a user trying to create a folder in root's home, you will not be able to. Root, remember, is the super-administration user, so root can create a folder anywhere.)
  • The arrows pointing left and right move you back and forward, respectively, through the directories you've already visited.
  • The wrench icon allows you to change your view preferences of the listed files and folders.

You can navigate through directories by just clicking on them, and double-clicking on a filename will instruct KWrite to open it.

Create a new document

  • We will use the terms document and file interchangeably.

To create a new document from scratch:

  • File->New.

This will display a blank screen in which you can create a document. This document will be based on default settings. Default settings are ones which are set up for you automatically.

Save the file to a location on a drive

When you work with a document on your computer, the working form resides in the computer's RAM. This is temporary memory used for your current activities. Since RAM is volatile, when the computer is switched off, everything that is in RAM is automatically lost. In order to keep your work you will need to transfer the contents of RAM to your hard disk. This process is called saving.

When you save a document, you give it a name and you specify where it is to be stored.

Save an existing document

If you have opened a document and made some changes, the process of saving it is very simple:

  • File->Save.

This will change the contents of the stored version so that it is identical to the version that is displayed on your screen. In this case, the previous version on disk is overwritten.

If you use File->Save in a newly created document, kwrite will automatically assume that you wish to use File->Save as.

Save a new document

When you create a document from scratch, there is no version stored on disk. To save the file to disk:

  • File->Save as.
The Save as dialogue will appear. In general, this will point to your home directory. It is very similar in appearance and functionality to the Open dialogue.


  1. If necessary, navigate to the directory in which you wish to save the file.
  2. Enter a name into the Location window.
  3. Click OK.

For the moment we will not be concerned with all the options in the Save as dialogue.

Closing KWrite

  • File->Quit

This will close all open documents and exit KWrite. If you have made any modifications to open documents, KWrite will remind you that the document has not been saved and ask you whether you wish to save or discard it. It will also give you the option of cancelling the Quit operation entirely.

Kwrite-close.png



Attribution-ShareAlike 2.5 You are free: To copy, distribute, display, and perform the work, To make derivative works, To make commercial use of the work Under the following conditions: by Attribution. You must attribute the work in the manner specified by the author or licensor who is: David Varley ICDL Foundation Copyright © 2004 ICDL Foundation.

Share Alike. If you alter, transform, or build upon this work, you may distribute the resulting work only under a license identical to this one. For any reuse or distribution, you must make clear to others the license terms of this work. Any of these conditions can be waived if you get permission from the copyright holder.

Personal tools