Migrating browser favorites

From MEPIS Documentation Wiki

Jump to: navigation, search

You will probably have a collection of favorite web pages that you would like to continue to use in MEPIS. Here are the steps to take with the most common browsers so that will happen.

Contents

Exporting favorites/bookmarks

MS IE 6

  • Start Internet Explorer.
  • Click File --> Import and Export....
  • The Import/Export Wizard will start. Press Next.
  • Select Export Favorites and press Next.
  • Select the folder from which you want to export your favorites. Selecting the Favorites folder will will export all of them. Press Next.
  • Select Export to a File or Address and choose a location and filename such as "IE6_Favorites" Press Next.
  • Completing the Import/Export Wizard will be displayed. Press Finish.

Your bookmarks will be copied to the location you specified.

Firefox/Iceweasel Bookmarks

  • Start Firefox/Iceweasel
  • Click Bookmarks --> Organize bookmarks
  • Make sure the bookmark folder you want (usually the top one) is highlighted
  • Click File --> Export...
  • Select the location you are using to save data for migration and click Save

Your bookmarks will be copied to the location you specified.

Firefox/Iceweasel Bookmarks, Passwords and Cookies

Sometimes copying the Bookmarks won't be enough for a complete migration. Unless you copy the Passwords and the related website Cookies, you will have to re-enter your site specific information all over again. Navigation through the sites is also aided by the Cookies, without them, it would be like visiting your favorite websites for the first time. Now, there are many ways of copying these files using addons, network links and online services, but, the easiest way is to just copy the specific files from one computer to another.

Before doing anything, make sure that Firefox/Iceweasel is closed on both the source and destination computers. Then follow these steps:

  • Go to the computer you will be copying from and bring up your home directory (click on the house icon on the panel).
  • Click View, then click Show Hidden Icons
  • When the hidden icons appear, click on .mozilla, then firefox, then XXXXXXX.default. Everyone has a unique default file, the ones I've seen are all numbers with a .default extension.
  • Locate and Copy these four files: (onto floppy, memory stick etc.)
bookmarks.html
cookies.txt
key3.db
signons2.txt
  • Go to the destination computer. Bring up the home directory.
  • Click View --> Show Hidden Icons --> .mozilla --> firefox --> XXXXXXX.default
  • Rename the following files:
bookmarks.html to bookmarks.html.old
cookies.txt to cookies.txt.old
key3.db to key3.db.old
signons2.txt to signons2.txt.old
  • Then copy the four files from the floppy/memory stick into the directory where you just renamed the files.

After you re-enter Firefox/Iceweasel, your Personal Toolbar should look the same on the destination computer, as it did on the source.

Opera

  • Start Opera
  • Click File --> Import and export
  • Select one option
    • Choose Export Opera bookmars if you are going to be using Opera in MEPIS
    • Choose Export bookmarks as HTML... if you will use a different browser in MEPIS
  • Select the location you are using to save data for migration and click OK

Your bookmarks will be copied to the location you specified.

Importing favorites/bookmarks

Firefox

  • Start Firefox by clicking KMenu --> Internet --> Web Browser (Firefox)
  • Click Bookmarks --> Organize Bookmarks...
  • Press File --> Import...
    • For Opera bookmarks (file name: opera6.adr), select Opera
    • For other browsers (including Internet Explorer), choose the From File option
  • Click Next
  • Find and select the exported file and press Open.

Your bookmarks/favorites should be imported.

Opera

  • Start Opera
  • Click File --> Import and export
  • Select the browser type whose bookmarks/favorites you want to import
  • Find and select the file exported from your Windows browser and press Open.

Your bookmarks/favorites should be imported.

Konqueror

  • Start Komqueror as a web browser by clicking KMenu --> Internet --> Web Browser (Konqueror)
  • Click Bookmarks --> Edit Bookmarks
  • Click File --> Import, and select the browser type whose bookmarks/favorites you want to import
  • Find and select the file exported from your Windows browser and press OK.

Your bookmarks/favorites should be imported.



Back to - - Windows to MEPIS migration (parent document)
Back to - - Migrating Windows Calendar data into MEPIS (previous page)
Back to - - MEPIS Wiki main page

Personal tools
In other languages